Posts Tagged 'Wii U'

Wii U and the default Warawara Plaza bug

Image

While this technically has nothing to do with game development, I thought I’d go ahead and post this since the internet is void of many answers. The short story is this: My Wii U Warawara plaza was only displaying the default Nintendo Miis as if I wasn’t connected to the internet.

The thing is, it used to work. It used to work just fine. Then one day it stopped. Well, that’s not technically true, I know exactly what I did. When I first set up my Wii U I put my Wife’s Mii as the default user. (It was a gift to her, so that seemed appropriate). ¬†After a few weeks she asked that the default Mii be changed to mine. (I don’t think she liked people using the ‘Yeah!’ function on her drawings and such). So that’s what I did, I changed the default user to my Mii and then Warawara plaza went back to the default plaza… and never changed back.

I searched for weeks trying to figure out how to fix it, but nothing I did worked. I made sure I had set up my Friends list, I could navigate the Miiverse just fine. People I ‘Followed’ in the Miiverse would show up in WaraWara Plaza, but it still didn’t look or act right.

Finally it started working again. I’m not sure ‘exactly’ how, but here’s what I did and why I think it worked. We have several games, each of which we’ve played at least once on the Wii U when the user was my Wife’s Mii. I know that there is cached data saved in the system about each game, and I know there is cached data for every game for every User Profile. After changing to my Mii I didn’t play every game again. I played all except 1: Zombie U. (I’d been wrapped up with Arkham City and Mario Bros). When I finally put the Zombie U disc in yesterday everything in WaraWara started working again. I think that every game needed to have some initialization data saved in the User Profile in order to access the System information. ¬†Since I was missing the Zombie U files, Warawara must have hit a false condition and just hung with the default plaza.

This is all observational, nothing scientific about my theory, but seeing as dozens of other Wii U owners have this issue I thought I’d put this up as a possible solution.

Advertisements